Jump to content

Profile page loading extremely slowly


Go to solution Solved by Myr,

Recommended Posts

Title says it all. This has been happening for quite a while now, and it never used to be an issue, but has become one for me.

So far as I can tell, the issue seems to be in the 'Activity' tab, when the profile in question reaches the point where it has to load the preview of the most recent chapter posted. Chapter comments, status updates -- those are fine. The preview itself though, loads like fucking treacle -- and it's the entire chapter. Seriously, it seems like the page is parsing the entire chapter very very slowly (it's just text, so WHY is it taking so long to do this?!), then once it is finished loading, only the first THREE LINES are actually displayed in the preview. Seriously, the third chapter of Lucid Truth includes not even the first paragraph of about 6000 words in the preview, so honestly this is really weird to me.

This never used to be the case. Not on my mobile, nor on my desktop, and I have upgraded my cellphone since this started to be an issue maybe a month or two ago, and the problem has nevertheless persisted.

See this status update for more personalised bitching on the topic.

Myr, your understanding and engagement is appreciated as always. I am actually surprised that nobody else has (apparently?) experienced this and reported it, so perhaps it is some very localised and specific problem, but it sure doesn't seem like it.

  • Like 2
Link to comment
  • Site Administrator
1 hour ago, Stellar said:

Doesn't seem to be any notable change, I don't think?

Then that eliminated one possible cause. thank you.  We're still investigating.

  • Like 2
Link to comment

Do you by chance have some filtering software on your devices that might be slowing that feature down?  I know that is a long shot, but is a possibility.

Also, my ISP [Internet Service Provider] has filters on some stuff, and I never know when they will show up and slow something down.  Usually, they don't filter anything, but sometimes the craziest things seem to set it off, and the ISP will ask me if I want so see such-and-such.

  • Like 3
Link to comment
  • Site Administrator

Just an update here.  I'm still not able to recreate the issue on my devices, nor is there any indications of an issue on the various test services.

There is an issue being noticed in 'real world data' on Google Chrome though where the profiles are lowing slower. We are still working on it.

  • Like 3
Link to comment
On 8/27/2021 at 6:22 AM, ReaderPaul said:

Do you by chance have some filtering software on your devices that might be slowing that feature down?  I know that is a long shot, but is a possibility.

Also, my ISP [Internet Service Provider] has filters on some stuff, and I never know when they will show up and slow something down.  Usually, they don't filter anything, but sometimes the craziest things seem to set it off, and the ISP will ask me if I want so see such-and-such.

No, I don't.

Considering that this happens on my desktop and through my mobile also, which use different providers, I doubt that's the issue.

2 minutes ago, Myr said:

Just an update here.  I'm still not able to recreate the issue on my devices, nor is there any indications of an issue on the various test services.

There is an issue being noticed in 'real world data' on Google Chrome though where the profiles are lowing slower. We are still working on it.

Thanks for the update! I'm honestly not holding my breath, so I'll be pleasantly surprised if you can nail this one down, haha.

  • Like 2
Link to comment
  • Site Administrator

Works fine with no issues in Firefox.
I am able to get it to load slow in Edge. Chrome is choking. Makes sense since Edge uses the Chromium Engine under the hood.

Still looking into why...

  • Like 2
Link to comment

I use Chrome as my primary browser, and I am not having trouble loading Stellar's profile at all.  Or, for that matter, any profile.  Haven't had any trouble on Edge, either.  

  • Like 1
Link to comment
2 minutes ago, ReaderPaul said:

I use Chrome as my primary browser, and I am not having trouble loading Stellar's profile at all.  Or, for that matter, any profile.  Haven't had any trouble on Edge, either.  

Could be device related. I'm on a tablet.

  • Like 1
Link to comment
27 minutes ago, ReaderPaul said:

I don't have any trouble on my Android phones, either.

Well, Stellar's profile won't load from my phone. I've never seen an issue like this with a profile here.

  • Wow 1
Link to comment
4 minutes ago, drpaladin said:

Well, Stellar's profile won't load from my phone. I've never seen an issue like this with a profile here.

That's weird.  As a site moderator, I would have thought you would have even less trouble than any of us.  I know software can cause problems, and sometimes seemingly random....

  • Like 1
Link to comment

Stellar's profile won't load on my desktop, either.  I am using Vivaldi on Windows 10.  Is the Vivaldi engine Chrome-based?  If so, that would tend to confirm others' Chrome-related problems.

On the other hand, my profile loads almost instantaneously.  What is the difference between our profiles?

 

  • Wow 1
Link to comment
1 hour ago, BigBen said:

Stellar's profile won't load on my desktop, either.  I am using Vivaldi on Windows 10.  Is the Vivaldi engine Chrome-based?  If so, that would tend to confirm others' Chrome-related problems.

On the other hand, my profile loads almost instantaneously.  What is the difference between our profiles?

 

Yes, it uses the Chromium  engine.

  • Like 1
Link to comment

This piqued my interest and I checked with my 6 year old Windows 10 PC with the latest update - Google Chrome latest iteration, iPad Pro 10.5" - Safari and Chrome latest iterations, and iPhone X - Safari and Chrome latest iterations and I had no issues with loading Stellar's profile. The Stories page for Stellar popped up instantly as well.

  • Like 1
Link to comment
  • Site Administrator

@Stellar, can you try it again now and let me know if you are still experiencing the issue?

 

  • Like 1
  • Love 1
Link to comment
2 minutes ago, Myr said:

@Stellar, can you try it again now and let me know if you are still experiencing the issue?

Tested it on both desktop and mobile, and the lag seems to be gone. Fantastic.

  • Like 1
  • Love 1
Link to comment
  • Site Administrator
  • Solution
1 minute ago, Stellar said:

Tested it on both desktop and mobile, and the lag seems to be gone. Fantastic.

Excellent!  The programmer was able to stick in a hard limit on the activity feed so it's not trying to process a full chapter.  Apparently, Chrome wasn't handling it the same was as other browsers.  It should now be working across the board and I found it to be noticeably faster too on Firefox.

  • Like 3
Link to comment

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×
×
  • Create New...

Important Information

Our Privacy Policy can be found here. We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue..